Marcos Birro Calixto
Criador Marcos Birro Calixto 28/12/2020

Carlos, como o curso do laravel 8 consiste em crud e upload a pergunta é se os pacotes que instalei no laravel 5.5 funcionam no 8 conforme json:

"php": ">=7.0.0",

        "barryvdh/laravel-dompdf": "^0.8.3",

        "fideloper/proxy": "~4.0",

        "jeroennoten/laravel-adminlte": "^1.24",

        "laravel/framework": "5.8.*",

        "laravel/tinker": "~1.0",

        "laravelcollective/html": "^5.8.x-dev",

        "maatwebsite/excel": "^3.1",

        "tymon/jwt-auth": "dev-develop",

 

        "guzzlehttp/guzzle": "~6.0"

Claro que usarei a versão para 8. Pergunto porque não consigo atulalizar do laravel 5.8 para a versão 6. O colletive está dando pau.

Manager Carlos Ferreira 28/12/2020

Olá, Marcos!
Tudo bem?

Você vai precisar atualizar algumas coisinhas.

Ex, a versão do PHP precisa ser no mínimo 7.3:
"php": "^7.3",

Precisa conferir na guia "tags" de cada package qual é a versão mais atual, como por exemplo o DOMPDF do Laravel:
https://github.com/barryvdh/laravel-dompdf/tags

Carlos Ferreira
Sabe a Solução? Ajude a resolver!

Precisa estar logado para conseguir responder a este ticket!

Clique Aqui Para Entrar!